my.wbs - staff metrics system not updating with latest information
Incident Report for Warwick Business School
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 18:18 GMT
Investigating
We are currently investigating this issue.
Posted Mar 15, 2024 - 08:29 GMT
This incident affected: my.wbs (Metrics).