Print release not working
Incident Report for Warwick Business School
Resolved
Both WBS student and staff print release is now understood to be working. Apologies for the outage. We believe the root cause to be understood
Posted Nov 30, 2022 - 14:49 GMT
Investigating
We are currently investigating an issue where neither students nor staff can log into our printers to release print jobs.
Posted Nov 30, 2022 - 09:25 GMT
This incident affected: General.