Services 'at risk' due to wider power issues on Campus

Incident Report for Warwick Business School

Resolved

NationalGrid have confirmed the power issues are all resolved and closed their call. Details are at https://powercuts.nationalgrid.co.uk/CV47EZ . The issue of problems logging into the central university call tracking system ( ServiceNow) persists. Details about that are available at https://warwick.ac.uk/services/idg/it-status/
Posted Nov 12, 2025 - 17:35 GMT

Monitoring

Power has reportedly been restored to all buildings on campus. NationalGrid engineers are continuing to work on the underlying problem so we'll keep this call open until they confirm final resolution. Currently however there is believed to be no impact on any service specific to WBS but across the wider campus customers and staff are unable to log into the central university's IT call tracking system ServiceNow. The latest details are at https://warwick.ac.uk/services/idg/it-status/
Posted Nov 12, 2025 - 14:35 GMT

Investigating

There are currently power issues affecting parts of the University of Warwick. These are not currently believed to be affected WBS services but such services should be considered at risk to disruption. Wider University services may be impacted.

More details can be found at https://warwick.ac.uk/services/idg/it-status/ including a link to the NationalGrid incident report at https://powercuts.nationalgrid.co.uk/CV47EZ
Posted Nov 12, 2025 - 12:14 GMT
This incident affected: General.