Student print release not working
Incident Report for Warwick Business School
Resolved
The student print release services is back working again. We will continue to investigate the root cause.
Posted Nov 29, 2022 - 14:41 GMT
Investigating
We are aware that students currently are unable to log into our printers in order to release print jobs. We are actively investigating
Posted Nov 29, 2022 - 14:07 GMT
This incident affected: General.