my.wbs - currently unable to save any information

Incident Report for Warwick Business School

Resolved

We believe we have resolved the issue that was preventing saving in my.wbs.
Posted Jun 30, 2026 - 16:47 BST

Investigating

We are currently investigating this issue
Posted Jun 30, 2026 - 16:40 BST
This incident affected: my.wbs (Site availability).