Network problems campus wide

Incident Report for Warwick Business School

Resolved

The network connectivity is working again
Posted May 30, 2026 - 13:32 BST

Investigating

Multiple websites across campus are currently unavailable including Warwick.ac.uk and my.wbs.ac.uk. Central networking teams are aware.
Posted May 30, 2026 - 13:29 BST
This incident affected: my.wbs (Site availability) and mini-my : Site availability, www.wbs : Site availability check, General.