my.wbs - assignment submission issues
Incident Report for Warwick Business School
Postmortem

Update on the Assignment Submission Interruption

What Happened?

From 20:26 on the evening of 20th March 2024, we encountered an issue affecting the MyWBS platform that prevented a subset of students from submitting their assignments. This issue persisted until 10:21 on the morning of 21st March. During this period, some users also experienced difficulties uploading certain resources and images.

Why did this happen?

The problem was traced back to a space issue on our web servers, which was unexpectedly caused by a new integration to a 3rd party commercial platform, Kaltura, that was configured to log activities at an unusually high level.

Impact on You

  • Assignment Submission: Some students were unable to submit their assignments within the specified time frame.
  • Resource Uploading: Difficulties were encountered when trying to upload certain resources and images.

What We've Done

We identified and addressed the underlying issue, restoring full functionality to MyWBS by 10:21 AM on 21st March. Our IT team has informed Kaltura of this unhelpful setting with the aim of helping other customers avoid problems.

Learning and Improvements

This incident has highlighted the importance of a more robust alert management. We are taking steps to ensure critical system alerts about storage issues reach the relevant personnel promptly, improving our ability to respond to and mitigate such issues swiftly.

Our Commitment to You

We apologise for any inconvenience this may have caused and are dedicated to ensuring the reliability and efficiency of our digital services. Your patience and understanding as we worked to resolve this issue are greatly appreciated.

For further assistance or to report any ongoing issues, please do not hesitate to contact us at help@wbs.ac.uk. If you believe this incident affected your academic performance please contact your program administrative team. They will have been made aware of this issue.

Posted Mar 22, 2024 - 17:53 GMT

Resolved
This incident has been resolved. Apologies for any anxiety or stress caused as a result of being unable to submit assignments.
Posted Mar 21, 2024 - 10:22 GMT
Identified
The issue has been identified, we're having to restart the servers to fix this.
Posted Mar 21, 2024 - 10:08 GMT
Update
We are aware that is also affecting the ability to upload attachments / images on any resources in my.wbs
Posted Mar 21, 2024 - 09:24 GMT
Update
We are continuing to investigate this issue.
Posted Mar 21, 2024 - 09:22 GMT
Investigating
We are aware that some students are unable to submit their assignment. We are investigating.
Posted Mar 21, 2024 - 08:30 GMT
This incident affected: my.wbs (Assignment Submission, Content Management System).