my.wbs - marking issues

Incident Report for Warwick Business School

Resolved

This incident has been resolved.
Posted Jun 10, 2025 - 14:43 BST

Investigating

We are aware of an issue when trying to save cohort feedback. We are investigating.
Posted Jun 10, 2025 - 10:00 BST
This incident affected: my.wbs (Marking).