This was caused by a technical issue during a system update, which has now been fixed. We apologise for any inconvenience caused.
Posted Jun 09, 2026 - 13:28 BST
Investigating
We are actively investigating reports of problems with users unable to access the home page at this time in my.wbs. Will post further information at https://status.wbs.ac.uk as soon as we have it.
Posted Jun 09, 2026 - 09:14 BST
This incident affected: my.wbs (Site availability).